Technikai részletek
| Alkalmazási réteg | SIP | |||
| Szállítási réteg | UDP | TCP | ||
| Hálózati réteg | IP | |||
| Adatkapcsolati réteg | Ethernet | Token Ring |
FDDI | ... |
SIP (Session Initiation Protocol)
Protokoll:
Internetprotokoll
Felhasználási
terület:
Internet-kommunikáció és együttműködés
Port: 5060
5061 (titkosított)
A protokoll-
hierarchiában:
Szabványok:
RFC 2543 (Session Initiation Protocol, 1999)
RFC 3261 (Session Initiation Protocol, 2004)
A H.323-mal szemben, amelyet a ITU-T dolgozott ki, a SIP-et kifejezetten az internetre való tekintettel az IETF mérnökei fejlesztették ki, abból a célból, hogy alkalmas legyen gyors és hatékony internet-alkalmazások fejlesztésére. Ezért kezdettől figyelembe vették a könnyű implementálhatóságot, skálázhatóságot, a kiterjeszthetőséget és a flexibilitást.
A SIP-pel tetszés szerinti sessiont (kapcsolatot) lehet egy vagy több felhasználóhoz rendelni. Egy session itt nem csupán az interneten történő telefonálást jelenti, hanem egyúttal különböző multimédia-csomagok átvitelét, konferenciakezelést, számítógépes játékok kapcsolatát, stb.
Ehhez kialakítottak egy ún. SIP-címet, amihez mindig hozzárendelődik a felhasználó aktuális IP-címe. Ez azt a lehetőséget nyújtja, hogy az ember egy címen legyen elérhető akkor is ha telefont, levelezést vagy más kommunikációs csatornát használ.
Az interneten történő telefonálás (VoIP) megvalósításához önmagánál a SIP-nél kicsit többre van szükség, a SIP ugyanis valójában csak a kommunikációs csatornák összekapcsolásához nyújt megoldást. A kommunikációs csatornákon folyó adatok tényleges összekapcsolásához más, kifejezetten erre a célra megalkotott protokollokat kell egymáshoz illeszteni. Erre szolgál a Session Description Protocol (SDP, RFC 3407) valamint a Real-time Transport Protocol (RTP, RFC 3550). Az SDP a végpontokon használt kodekek, transzportprotokollok összeegyeztetéséért felelős, az RTP feladata a multimédia-adatfolyam átvitele, vagyis hogy a megfelelő kodekkel kódolt és tömörített adatot csomagokra bontsa, és az UDP-n keresztül elküldje.
A SIP hasonlít a HTTP-protokollhoz: hasonló fejlécstruktúrát használ, valamit ugyanúgy szöveges protokoll. A felhasználók címzési módja az e-mail-írásnál megszokott ún. URI formátum: sip:user@domain. Egy további címzési mechanizmus az ún. Tel-URI formátum, amit az RFC 3966 ír le, pl.: tel:+36-1-1234567. Ez utóbbi igény szerint átalakítható a SIP-URI formátumra, pl.: sip:+36-1-1234567@domain.
A SIP különböző gyártók egyre több készülékében talál támogatásra, és úgy tűnik, lassan a Voice over IP (VoIP) standard protokolljává fejlődik. A SIP-et választotta protokollnak a 3rd Generation Partnership Project (3GPP) a harmadik generációs mobiltelefónia (UMTS) multimédia-támogatására, valamint a SIP-re épül a Next Generation Network (Újgenerációs hálózatok) specifikációja is, amit a European Telecommunications Standards Institute (ETSI) Telecommunications and Internet converged Services and Protocols for Advanced Networking (TISPAN) projektcsoportja alakított ki.